Lincoln MKZ Forum banner

Trunk won't release/latch

24160 Views 10 Replies 10 Participants Last post by  PercyDM
I can't believe there's no exterior key option at all. Basically, if the power trunk won't work, you have to crawl through the folding seat and manually release it with the emergency cord. This is a really horrid design.

A couple months ago, my power-down feature stopped working reliably. Then the power lift stopped working reliably. Both would still work occasionally, but not reliably. Didn't matter to me, I don't care if I have to manually lift or close the trunk,. and everything else still worked.

Then a few days ago, the trunk pop button didn't work. Used the remote - nothing. Tried a few times, finally worked. Didn't think much of it.

It's been getting progressively worse, and as of yesterday, i had to crawl through and pop the trunk manually twice while running errands. Thankfully it worked fine when I had customers with luggage. When it won't pop, it also wont cinch. Like, when i close it, it'll LATCH - but it won't motor down tightly and stays "loose".

Today it has stopped working completely. I had to crawl through to release it both on pickup and drop off of an airport customer - talk about embarrassing.

Everything says to disconnect the battery and perform a BCU reset, but I fail to see how that could change anything. The BCU seems to believe it's working, because when I use the remote to pop or close it, it flashes the lights and pretends it's doing the thing - it just doesn't actually do the thing. Weirdly, it also doesn't seem, to know the trunk is open. No warning message or lights, nothing saying the trunk is ajar - even when I *know* it is.

Anyone come across this before..? Is it a BCU issue, or should I replace the trunk latch motor? Why would the power up and down motor and the release/latch motor both crap the bed at almost the same time? Or for that matter - why separately? And why on earth would EITHER of these things affect the ability of the car to know if the trunk is closed?!

See less See more
1 - 1 of 11 Posts
1 - 1 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.