Heated and cooled seats not working - Lincoln MKZ Forum
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 2 (permalink) Old 02-28-2020, 04:35 PM Thread Starter
Junior Member
 
Join Date: Feb 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Heated and cooled seats not working

I recently purchased a 2013 Mkz, and when i got the car the cooled seats worked perfectly but the drivers seat on the heat mode would kind of idle up and down and I'm not sure if this is normal operation, BUT after about a month both the drivers seat and passengers seats Heated and Cooled seats just all the sudden stopped working. The display shows them to be on, but nothing from the seat itself. I have checked the #65 fuse on the car and it appears to be fine. I also checked the wires under the seat and it seems like all the connections are plugged in. I was wondering if anyones had this issue with their Mkz and if anyone had any suggestions? I have black seats and in the winter heated seats are nice and in the summer i would really like to use the cooled seats.
Zac O is offline  
post #2 of 2 (permalink) Old 09-14-2020, 01:59 AM
Junior Member
 
Join Date: Aug 2020
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A good heater service shop can totally fix that! They've fixed my same problem in a breeze. https:// mzaircon.com.au
g1987adams is offline  
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome