Lincoln MKZ Forum - View Single Post - 2011 mkz awd ptu
View Single Post
post #1 of (permalink) Old 06-05-2014, 10:23 AM Thread Starter
jrasero23
Junior Member
 
Join Date: Apr 2014
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2011 mkz awd ptu

Just got a CPO 2011 MKZ AWD a month and a half ago. Bought it with 38k and have 40k on it now.

So far the car has been wonderful besides two things:

The rear 2 taillight LED lights were out and they had to replace module. Would have been over $400 but covered by warranty

BUT more importantly while driving 10-20+ miles I noticed occasionally a gas like smell. It doesn't enter the cabin unless my moon roof or windows are down but it is a strong smell.

After some basic research without going under the car it became clear there was a 90% chance this was a PTU leak.

Took the car to the dealer and they confirmed it was a PTU leak. They are ordering the part and it should be done and hopefully fixed for good in 3-5 days.

Through my research I have seen very few cases of Fusion AWD having this problem and no MKZ AWD with this problem online, rather most reporting PTU problems were Edges AWD or MKX AWD. Does anyone else who has a 2010-2012 MKZ AWD have or had this problem? Does the PTU replacement seal fix the problem for good?
jrasero23 is offline  
 

Search Tags for this Page

lincoln mkz forum

,
mkz forum
,
2014 mkz
,
2014 lincoln mkz
,
mkz hybrid
,
lincoln mkz hybrid
 
For the best viewing experience please update your browser to Google Chrome